V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
raysonx
V2EX  ›  宽带症候群

开启 IPv6 后网速变得很慢?可能是 PMTU 黑洞的问题

  •  1
     
  •   raysonx · 86 天前 · 3405 次点击
    这是一个创建于 86 天前的主题,其中的信息可能已经有所发展或是发生改变。

    发现最近经常有人提到开启 IPv6 连接速度慢的问题。目前国内确实存在支持 IPv6 的服务器、CDN 节点不够多,IPv6 国际带宽比 IPv4 带宽小的问题,但也不至于会打开国内网站都卡。通常情况下遇到这个问题说明你到目标服务器的链路上存在 PMTU 黑洞。

    关于 PMTU 黑洞

    MTU (Maximum transmission unit) 是一条链路上可以通过的三层数据包的最大尺寸(包含 IP 包头)。以太网上默认的 MTU 是 1500 字节,但是你和目标服务器之间的路径上可能存在小于 MTU 1500 的链路。这条路径上最小的 MTU 值就是整条路径的 PMTU 值。路由器在转发包时,超过 MTU 大小的包会被分片( Fragmentation ),也就是一个大包会被分切为多个不超过 MTU 的小包进行传输,传输效率会下降。

    终端设备在发包时,也可以设置 DF ( Don't Fragment )标记来告诉路由器不要分片。这时中间路由器会丢掉超过 MTU 的包,回复一条 ICMP Fragmentation Needed 消息。发送者收到这个包后,下次就会发小一点的包,这个过程叫做 PMTU Discovery 。现实中可以看到 HTTPS ( TLS )的流量大都是带 DF 标记的。

    然而,互联网上有大量的中间设备为了所谓的“安全”或者没有正确配置,不回应 ICMP Fragmentation Needed 包,这使得访问某些网站时如果某个包的大小超过了 PMTU,会被无声地丢弃,直到 TCP 协议发现超时丢包进行重传,这非常缓慢。遇到这种情况,我们可以说你和目标服务器的路径上存在 PMTU 黑洞。

    此外,IPv6 不支持分片,换句话说可以理解为 IPv6 下所有的包都是带 DF 标记的。中间路由器在遇到包尺寸大于 MTU 的情况时,应该回应 ICMPv6 Packet Too Big 消息。同样的,由于种种原因,某些中间设备可能会直接丢包而不回应 ICMPv6 Packet Too Big 消息,直到 TCP 协议发现超时丢包进行重传。。。

    为什么 IPv4 没有这个问题

    其实 IPv4 也有这个问题,我不只一次见网友说自己搭的软路由访问某些网站非常慢,而换回硬路由就正常。这是因为多数家用路由器默认对 IPv4 下的 TCP 开启了 MSS (maximum segment size) Clamping (使用 OpenWRT 软路由的朋友们可以在防火墙设置中找到 MSS Clamping 开关)。MSS Clamping 是针对 PMTU 黑洞的 Workaround,简单来说就是 TCP 握手时有个 MSS 字段决定单个 TCP 包的最大尺寸。路由器可以通过嗅探 TCP 握手包,把 MSS 值改小,使最终的三层 IP 包的尺寸( MSS+TCP 头大小+IP 头大小)不超过某个特定的值。

    总结

    现在国内 ISP 一般都是通过 PPPoE 虚拟拨号建立 WAN 口连接的。Ethernet 的默认 MTU 是 1500,但是 PPPoE 隧道有 8 个 bytes 的开销,所以 PPPoE 虚连接的 MTU 就是 1500-8=1492,减掉 IPv4 包头( 20 字节)和 TCP 包头( 20 字节),可以得知 IPv4 下需要把 MSS 设为 1452 以下。

    IPv6 的包头是 40 字节,所以 IPv6 下需要把 MSS 设为 1432 以下。

    这时问题来了,目前很多光猫、家用路由器对 IPv6 的优化很差,不支持对 IPv6 下的 TCP 包进行 MSS Clamping,这就导致访问 IPv6 网站时,若路径中存在 PMTU 黑洞,则打开很慢。

    我前段时间帮朋友配置 IPv6 时发现了很多光猫、家用路由器的固件问题,使得国内使用 IPv6 的体验不太理想。我打算抽空专门开一个帖子去讨论这些问题,声讨那些垃圾厂家。目前来看,要想在国内比较理想地体验 IPv6,你需要把光猫改为桥接模式,并使用 OpenWRT 或者 VyOS 这类对 IPv6 支持较好的软路由。

    第 1 条附言  ·  86 天前

    附:在基于 Linux 的路由器启用MSS Clamping的命令:

    # 自动MSS,假设PPPOE虚接口是pppoe0
    iptables -t mangle -A POSTROUTING -p tcp --tcp-flags SYN,RST SYN -o pppoe0 -j TCPMSS --clamp-mss-to-pmtu
    ip6tables -t mangle -A POSTROUTING -p tcp --tcp-flags SYN,RST SYN -o pppoe0 -j TCPMSS --clamp-mss-to-pmtu
    
    # 手动指定MSS,假设PPPOE虚接口是pppoe0
    $ iptables -t mangle -A POSTROUTING -p tcp --tcp-flags SYN,RST SYN -o pppoe0 -j TCPMSS --set-mss 1452
    $ ip6tables -t mangle -A POSTROUTING -p tcp --tcp-flags SYN,RST SYN -o pppoe0 -j TCPMSS --set-mss 1432
    
    第 2 条附言  ·  84 天前

    感谢 @Danswerme 提供RouterOS里设置MSS的命令。其中pppoe-out1是wan口,1420是要MSS值,请根据需要修改。

    /ipv6 firewall mangle add chain=forward out-interface=pppoe-out1 protocol=tcp tcp-flags=syn action=change-mss new-mss=1420
    
    第 3 条附言  ·  81 天前

    感谢 @PublicDNS 分享 UBNT Edgerouter 系列的MSS设置方法:

    set firewall options mss-clamp6 interface-type pppoe
    set firewall options mss-clamp6 mss 1420
    
    35 条回复    2021-11-24 10:13:02 +08:00
    yov123456
        1
    yov123456   86 天前
    赞,当时 erx 的时候也折腾了很久
    vwxc
        2
    vwxc   86 天前 via Android
    谢谢分享,有空试试看,之前都是直接关掉 v6 下发
    icegaze
        3
    icegaze   86 天前 via Android
    学习了,
    openwrt 在防火墙里没有找到 MSS clamping 的设置,望楼主指点迷津。
    icegaze
        4
    icegaze   86 天前 via Android
    找到了,

    在 网络--防火墙--区域 那里,可以打勾,设置上。

    多谢多谢。
    samondlee
        5
    samondlee   85 天前
    az,华硕路由默认推荐的 1492 需不需要改成 1452
    wszgrcy
        6
    wszgrcy   85 天前
    感谢.原来是这样,我就是开 ipv6 后有些网站死慢的....
    xiaooloong
        7
    xiaooloong   85 天前
    pfsense 的 ipv6 遇到这个问题了。家里是联通的宽带,装机的时候直接让师傅改了桥接,这边联通又默认给了公网 ip 就一直没折腾 ipv6 。后来换了 openwrt 用了一下发现居然有 ipv6 。才知道 ipv6 是直接跑在 pppoe 里用 dhcpv6 client 获取的。开启之后 ipv6 测试网直接就说我 v6 的 mtu 有问题。往上查了一下说是因为 pfsense 计算 v6 的 mss 直接用了 v4 的参数导致的 bug 。虽然官方说已经在 2.5.1 修复但是我遇到问题的正式 2.5.1 。最后还是手动改了 mss 才这正常的。
    raysonx
        8
    raysonx   85 天前 via iPad
    @xiaooloong pfSense 好多年没有用了,不知道现在情况怎么样,好像开发不怎么频繁的样子。我看国外很多老用户都转向了 OPNsense,你可以试试看。
    phxsuns
        9
    phxsuns   85 天前
    谢谢分享。
    我是无奈才关了 IPv6 的,开了就是慢。看起来就是这个原因。
    thtznet
        10
    thtznet   85 天前
    现阶段用 IPv6 也没什么好处,业界既然不成熟,就不开了。
    raysonx
        11
    raysonx   85 天前
    @thtznet 其实协议和技术本身都很成熟,IPv6 在设计之初也顺带解决了一些 IPv4 的设计缺陷(比如组播、广播风暴等),主流操作系统的支持也没问题,但小厂商的设备真的是一言难尽。
    xhcnb
        12
    xhcnb   85 天前
    谢谢分享! 之前没有考虑到这一层
    这就去把 ipv6 再打开试试
    Unclev21x
        13
    Unclev21x   85 天前
    贴主求教。
    光猫桥接,路由器刷了梅林固件,路由器开启 IPv6,ipv6-test 测试结果正常,各设备都能拿到 IPv6 的地址。手机上用 Safari 看一些 IPTV 的时候,浏览器地址栏的域名自动切换到了 IPv6 地址。
    问题(举例说明):
    有个在线广播电台合集的网站(必须科学上网才能听),不管是通过浏览器,还是官方 App 去收听节目的时候,如果开启了 IPv6,就听不了。如果关掉 IPv6,马上就可以收听。

    这个问题的原因我现在不知道是什么,可能的原因如下:
    1. 代理问题。路由器上开启了代理,但是 IPv6 访问的时候没有走代理(如果是这样,怎么强制让 IPV6 的流量走代理?);
    2. IPv6 问题。如果走了 IPv6,就是不能收听。
    Unclev21x
        14
    Unclev21x   85 天前
    @Unclev21x 好几个网站都遇到这样的情况了。似乎设备上的 IPv6 的地址默认就是公网地址了。
    raysonx
        15
    raysonx   85 天前
    @Unclev21x 仅凭你的描述我也无法断定问题所在,但能肯定的是这个在线广播的域名解析到了一个你不能访问的 IPv6 。如果你的代理不支持 IPv6,你可能需要屏蔽这个域名的 AAAA 记录和 TYPE65 记录。
    KnightNic
        16
    KnightNic   85 天前
    我们这儿天翼网关要是改成桥接,千兆宽带就只剩 500 兆了,不知道什么原因。
    raysonx
        17
    raysonx   85 天前
    @KnightNic 光猫的的问题。你的光猫可能是软桥接,无硬件加速,CPU 性能不足以支持千兆。
    KnightNic
        18
    KnightNic   85 天前
    @raysonx 可能还不一定是性能问题呢,早前 500 兆的宽带,改桥接可以 500 兆满速,后来从某段时间开始就不行了,只要改了桥接就变成半速。500 兆变 250 兆,千兆变 500 兆。
    guanyin9cn
        19
    guanyin9cn   85 天前
    1412

    [[email protected] /mnt/jffs2/hw/bin] # iptables-save | grep MSS
    -A PREROUTING -i ppp257 -p tcp -m tcp --tcp-flags SYN,RST,ACK SYN -m tcpmss --mss 1412:65535 -j TCPMSS --set-mss 1412
    guanyin9cn
        20
    guanyin9cn   85 天前
    hw 光猫 默认都是 1412.
    guanyin9cn
        21
    guanyin9cn   85 天前
    更正下,上面贴的是 v4 的

    v6

    [[email protected] /mnt/jffs2/hw/bin] # ip6tables-save | grep MSS
    -A PREROUTING -i ppp257 -p tcp -m tcp --tcp-flags SYN,RST,ACK SYN -m tcpmss --mss 1392:65535 -j TCPMSS --set-mss 1392
    guanyin9cn
        22
    guanyin9cn   85 天前
    @Unclev21x

    dnsmasq 里添加一行。

    address=/电台域名 /::
    tankren
        23
    tankren   84 天前
    @xiaooloong #7 本来就是要手动设置 MTU 和 MSS 的啊 默认是 1500 全都放 1492 就可以,WAN 的 ipv6 用 track interface,然后 RA 设置 Assisted
    tankren
        24
    tankren   84 天前
    @xiaooloong #7 2.5.1 改的那个 bug 是对于 IPV6 MSS 的设置值减的是 IPV4 的 40 不是 60 原来要设置成 1472 才没问题
    Unclev21x
        25
    Unclev21x   84 天前
    @guanyin9cn 谢谢。我晚上回去就试试。
    但我还是有些不明白。路由器开启科学上网(手机不开启)+IPv6 的情况下,手机拿到的 IPv6 地址是公网地址,这个时候访问电台,无法收听。打开 https://ifconfig.co/这个网站,显示的是 IPv6 地址。ping 这个域名的时候,解析出来的地址也是 IPv6 地址。接着,我在手机上也打开小火煎,之后就可以收听了。刷新 https://ifconfig.co/ ,显示的 IPv4 地址了。所以我就怀疑 IPv6 没有走代理(不知道是不是因为代理服务器不支持 IPv6 )。
    Exin
        26
    Exin   84 天前
    学习了,讲得好清楚
    Danswerme
        27
    Danswerme   84 天前   ❤️ 2
    感谢楼主分享,因为 IPv6 下打不开简书,本来我都把 IPv6 关掉了。想起来你提到的 MTU 的问题,刚才到家后用 wireshark 抓包看了下,发现其中有一条是这样的:`tcp previous segment not captured`。
    然后在防火墙里把 MSS 改成 1420,果然就恢复正常了,再次感谢楼主。

    分享下 RouterOS 里修改 MSS 的脚本: `/ipv6 firewall mangle add chain=forward out-interface=pppoe
    -out1 protocol=tcp tcp-flags=syn action=change-mss new-mss=1420`
    raysonx
        28
    raysonx   84 天前
    @Danswerme 感谢分享 RouterOS 的设置命令
    PublicDNS
        29
    PublicDNS   83 天前 via Android
    erx 用户

    set firewall options mss-clamp6 interface-type pppoe
    set firewall options mss-clamp6 mss 1420
    littlewing
        30
    littlewing   82 天前
    @Danswerme 我也是 IPv6 打不开简书,然后没找到原因,感谢
    darrh00
        31
    darrh00   82 天前
    讨论过好多次了吧?

    https://www.v2ex.com/t/688028
    raysonx
        32
    raysonx   81 天前
    @PublicDNS 感谢分享。
    ppbaozi
        33
    ppbaozi   15 天前
    routeros 似乎只需要设置 ipv6 > nd 里面的 mtu 值就行了
    microka
        34
    microka   7 天前
    @Danswerme #27 非常感谢,刚给 RouterOS 开启了 IPv6 ,发现无法访问简书,按照您的指导操作完马上可以了!
    Danswerme
        35
    Danswerme   6 天前
    @microka 客气了,也要谢谢楼主的分享,能帮到大家就是最好的。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2524 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 00:54 · PVG 08:54 · LAX 16:54 · JFK 19:54
    ♥ Do have faith in what you're doing.