V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
g001
V2EX  ›  macOS

macos12 不支持 PHP ?

  •  
  •   g001 · 242 天前 · 2749 次点击
    这是一个创建于 242 天前的主题,其中的信息可能已经有所发展或是发生改变。

    什么骚操作,mac12 更新后,就不在支持 php 了,自己安装 php 也不行

    20 条回复    2021-12-18 16:15:45 +08:00
    Chism
        1
    Chism  
       242 天前
    docker
    evam
        2
    evam  
       242 天前
    能用啊。我用 brew 装的。
    说起来之前自带的 php 贼难卸载
    zhouxuchen
        3
    zhouxuchen  
       242 天前
    不会啊,可能你想装 7.3 以及之前的版本? [email protected] 在今年 12 月 6 日开始就不支持通过 brew 安装了,brew edit [email protected] ,把 disabled 开头的那行注释掉就行
    winddweb
        4
    winddweb  
       242 天前   ❤️ 3
    不自带 PHP ,自己装不行说明你没装好。
    Dvel
        5
    Dvel  
       242 天前
    Alfred 有些插件都失效了才发现,可以自己 brew 一个。
    acoldfox
        6
    acoldfox  
       242 天前
    我倒是好奇为什么之前 mac 会自带 php 呢?系统本身有用到 php 的地方吗
    wunonglin
        7
    wunonglin  
       242 天前
    ????brew 和 docker 不都可以用
    seanzxx
        8
    seanzxx  
       242 天前
    @acoldfox 不光带了 php ,也带了 ruby, python 呀,然后上一版里面就说会逐步删除掉系统自带的这些脚本引擎
    zachlhb
        9
    zachlhb  
       242 天前
    自己安装可以的,用 brew 的国内源安装
    c1273082756
        10
    c1273082756  
       242 天前
    shilianmlxg
        11
    shilianmlxg  
       242 天前
    那为什么不用 docker 装呢,还不污染环境
    huiyanpohundh123
        12
    huiyanpohundh123  
       242 天前
    手动编译 arm 版本的 php 就行了
    paopaosa
        13
    paopaosa  
       242 天前
    不支持和不自带是两个概念。可以自己装,比如用 macports 。
    chenzheyu
        14
    chenzheyu  
       242 天前
    @seanzxx 删除自带才好,你看 centos 自带的 php 跟 nginx 都是上古版本
    ekikaizeng
        15
    ekikaizeng  
       242 天前
    brew 可以装的 如果你要装老版本的 可以看一下这个 https://github.com/shivammathur/homebrew-php

    扩展的话要手动编译安装一下
    QlanQ
        16
    QlanQ  
       242 天前
    默认也删除了 python 吧
    guisheng
        17
    guisheng  
       242 天前 via iPhone   ❤️ 1
    觉得 docker 就在污染我的电脑。。。。
    volvo007
        18
    volvo007  
       242 天前
    @QlanQ 没有, 居然还能神奇的跑自带的 python 2.7……不知道魔改了啥

    This version is included in macOS for compatibility with legacy software.
    Future versions of macOS will not include Python 2.7.
    Instead, it is recommended that you transition to using 'python3' from within Terminal.
    [GCC Apple LLVM 13.0.0 (clang-1300.0.29.10) [+internal-os, ptrauth-isa=deployme on darwin
    demoshengxw
        19
    demoshengxw  
       242 天前 via Android
    直接 docker 拉个镜像,非常方便
    qq1204076437
        20
    qq1204076437  
       241 天前 via iPhone
    只是不自带,并不是不支持。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4360 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 120ms · UTC 01:55 · PVG 09:55 · LAX 18:55 · JFK 21:55
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.