V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Mogugugugu
V2EX  ›  JetBrains

AI Assistant in JetBrains IDEs

  •  
  •   Mogugugugu · 240 天前 · 5506 次点击
    这是一个创建于 240 天前的主题,其中的信息可能已经有所发展或是发生改变。
    来源: https://blog.jetbrains.com/idea/2023/06/ai-assistant-in-jetbrains-ides/

    好消息:原生支持 AI
    坏消息:不支持中国

    好消息:现在免费( EAP 周期)
    坏消息:定价模型在做了在做了...
    22 条回复    2023-07-22 10:35:57 +08:00
    zhs227
        1
    zhs227  
       240 天前
    我看之前的 fleet 里面上上次更新就有了,也用了一些时候,感觉和 copilot x 非常接近。因为 fleet 不如 vs code 流畅,目前用的比较少。
    t783072156
        2
    t783072156  
       240 天前   ❤️ 1
    这个国家限制怎么绕过去
    winterbells
        3
    winterbells  
       240 天前 via Android
    Android studio 最新的 canary 版也已经有了
    就是模型不太给力,问它 Android 上的问题都跟白痴一样。
    Abirdcfly
        4
    Abirdcfly  
       240 天前
    同问。怎么绕过国家限制....同样的 IP 下 OpenAI 可以访问,这个会 geo-block...
    DianAvA
        5
    DianAvA  
       240 天前
    不错呀,现在 IDEA 有什么好用的 AI 助手吗?
    twofox
        6
    twofox  
       240 天前
    @DianAvA GitHub copilot 算么? GitHub copilot chat 目前还只有 vs code 预览版,我也很希望他能早点上架 idea
    Mogugugugu
        7
    Mogugugugu  
    OP
       240 天前
    我用 Clash 开了代理,同时 jb account 的地区也不是中国,目前可以正常访问,但是感觉很慢。(相同的代理 无法访问 openai ,但是可以访问 AI Assistant )
    devdes
        8
    devdes  
       240 天前
    @Abirdcfly 从命令行启动
    TinyKube
        9
    TinyKube  
       240 天前
    用美国的代理可以绕过限制
    RageBubble
        10
    RageBubble  
       240 天前
    不支持中国这不算什么坏消息,好的东西大多都是国外的,能时不时给我带来惊喜的也大多都是国外的产品,习惯就好。
    而且都用 jetbrain 搞开发了,熟练翻墙和会点英语都应该是基本技能。
    t783072156
        11
    t783072156  
       240 天前
    @RageBubble 问题是这个我挂全局梯子都不行,不知道还需要什么操作
    RageBubble
        12
    RageBubble  
       240 天前
    @t783072156 现在只对有限用户开放。我的也没有,我到工具里面去查也没有找到这个 AI assistant 。
    patrickyoung
        13
    patrickyoung  
       240 天前 via iPhone
    @TinyKube #9 问问他是不是 openai 驱动的
    murmur
        14
    murmur  
       240 天前
    那就继续等 copilot 吧,现在默认版的模型还是老了,等用 gpt3.5 的新模型正式版就好的多
    agagega
        15
    agagega  
       240 天前 via iPhone
    @patrickyoung
    博客里面写了,就是用的 OpenAI 接口,所以才不支持中国
    imKiva
        16
    imKiva  
       240 天前   ❤️ 3
    试了一下,在已有的规则里加一条就可以绕过国家限制:
    DOMAIN-SUFFIX,grazie.aws.intellij.net
    qianyeyixi
        17
    qianyeyixi  
       240 天前
    @imKiva 6666
    Abirdcfly
        18
    Abirdcfly  
       239 天前
    是的,需要全局代理 api.app.prod.grazie.aws.intellij.net 才行。goland 里设置代理似乎对这个插件没效果。
    目前试下来,重构代码出问题较多...很多时候是原样输出了.....
    #4
    zxy148
        19
    zxy148  
       234 天前
    @devdes 怎么启动,我这边挂代理都没用
    devdes
        20
    devdes  
       233 天前
    @zxy148 我用的 Fleet ,terminal 已通过 export http_proxy=代理地址 设置好代理,进入包内部找到可执行文件,然后将路径复制到 terminal 中,通过 terminal 启动应用。
    alanhe421
        21
    alanhe421  
       226 天前
    1. IDE 层面代理还用不了原因是 AI Assistant 目前的版本没走 IDE 中的代理设定,官方已经修复了,还没发布,估计就是下一次的 EAP 了,一两周的事。目前想用就得是真正的全局代理,比如用 Surge 的增强模式之类的
    2. JB 这里的 AI Assistant ,人家公告写了,用的 OpenAI
    alanhe421
        22
    alanhe421  
       215 天前   ❤️ 1
    @alanhe421 更新下
    1. 插件未走 IDE 代理问题,fixed ,更新下,比如我这里 WebStorm v2023.2 RC 已修复
    2. 具体背后的 AI 技术介绍,https://www.jetbrains.com/legal/docs/terms/jetbrains-ai/service-providers/
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   3048 人在线   最高记录 6543   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 00:16 · PVG 08:16 · LAX 16:16 · JFK 19:16
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.