V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
jarence
V2EX  ›  macOS

请问大家如何解决 macOS 的 terminal 下 tmux 的窗口大小调节(Ctrl+b, Ctrl+up)不起作用的问题。

  •  
  •   jarence · 89 天前 · 629 次点击
    这是一个创建于 89 天前的主题,其中的信息可能已经有所发展或是发生改变。

    如题。

    8 条回复    2022-03-30 14:22:16 +08:00
    Kobayashi
        1
    Kobayashi  
       89 天前 via Android
    Ctrl-Up, Ctrl-Down 默认被 Mission Control 占用
    ruidoBlanco
        2
    ruidoBlanco  
       89 天前
    自定义一个专用于改变布局的 layout 。c-a m 进入,esc 退出,h i j k 改变大小,空格改变布局方式。

    https://github.com/roylez/dotfiles/blob/a47391a3d6500c0b40a29463ad6523c5aecb8b9c/tmux/.tmux.conf#L151
    Hack3rHan
        3
    Hack3rHan  
       89 天前
    改下配置文件,拿鼠标拖。
    jaredyam
        4
    jaredyam  
       89 天前
    # start with mouse mode enabled
    set -g mouse on
    jarence
        5
    jarence  
    OP
       89 天前
    @Hack3rHan @jaredyam 谢谢,开启鼠标过后,复制好像不行呢。
    jarence
        6
    jarence  
    OP
       89 天前
    @ruidoBlanco 这个配置不错,试试。感谢推荐。
    jaredyam
        7
    jaredyam  
       89 天前
    @jarence 鼠标选择复制区域,默认在 tmux 剪切板,使用 Ctrl + A, P 粘贴,如果需要 yank 到系统剪切板,使用是 Ctrl + A, Y ,在使用系统粘贴键。
    cattyhouse
        8
    cattyhouse  
       89 天前
    用 iterm2
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2906 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 18ms · UTC 11:29 · PVG 19:29 · LAX 04:29 · JFK 07:29
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.