V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
Cipool
V2EX  ›  宽带症候群

Openwrt 桥接后 IPv6 问题求助

  •  
  •   Cipool · 129 天前 · 3142 次点击
    这是一个创建于 129 天前的主题,其中的信息可能已经有所发展或是发生改变。

    通过超管密码登陆光猫,设置桥接模式,并打开了 IPv6 协议。 telecom

    使用 Openwrt 固件路由器进行 PPPoE 拨号,在状态页面,可见 dhcpv6 方式下发的 IPv6 /64 地址,但似乎没有下发(获取) PD 前缀。 lede1

    但在接口处查看,不知何故,WAN 口并无上图中的 /64 地址,也并未获取到公网 IPv6 地址,仅有一莫名其妙的内网地址。LAN 口自然也无法获取任何 IPv6 地址。 lede2

    目前只能用光猫拨号,路由器作为 AP 的组合,才能让局域网设备正常获取 IPv6 地址。现在桥接后,不知道如何能让 openwrt 路由器也能正常获取并下发 IPv6 地址,网络搜索良久也没找到合适的解决方案,烦请大家不吝赐教。

    第 1 条附言  ·  129 天前
    /etc/config/firewall 文件: https://write.as/3wq4y9vu7avrx.md
    /etc/config/network 文件: https://write.as/w0zys676vrpd2.md
    第 2 条附言  ·  129 天前
    感谢各位的倾囊相助,我根据大家的提示修改了 lan 口和 wan 口的配置,但均未起效。从大家的意见看,大家普遍认为问题还在于我使用的 openwrt 固件,这一点后期方便时,我会刷写原版的 openwrt 进行验证。目前,根据 @yaott2020 的提示,我使用 nat6 方式,可以让局域网内设备正常访问 IPv6 网络。
    47 条回复    2022-01-12 17:21:41 +08:00
    vtoex0000000002
        1
    vtoex0000000002  
       129 天前
    我也遇到了
    yaott2020
        2
    yaott2020  
       129 天前 via Android   ❤️ 1
    wan 那个 /64 不就是公网 v6 吗

    lan 要打开 dhcpv6
    ipv6 设置那里设置混合模式--混合模式--禁用--有状态无状态--总是通告默认路由
    Buges
        3
    Buges  
       129 天前 via Android   ❤️ 1
    openwrt 使用自动模式就可以。在你的 /etc/config/network 里大概是这样的:
    config interface 'wan'
    ......
    option ipv6 'auto'
    Love4Taylor
        4
    Love4Taylor  
       129 天前
    不是还要有一个 DHCPv6 Client 的接口么?
    CKR
        5
    CKR  
       129 天前 via Android   ❤️ 1
    lan 口 dhcp ipv6 设置那里没设置吧
    CKR
        6
    CKR  
       129 天前 via Android
    还有就是有些 openwrt 固件会默认禁止解析 ipv6 dns 记得在 dhcp/dns 的高级设置里面取消掉
    Cipool
        7
    Cipool  
    OP
       129 天前
    @yaott2020 感谢回复,在路由器 LAN 口内按照提示进行设置后,情况没有发生变化。另外在 IPv6 WAN 状态那里的确可见 /64 地址,但是 WAN 接口处却又显示一 fe80 开头地址,不知道是否与此有关。
    附 LAN 口设置图: https://img.mukewang.com/user/61dacc1b0001c5e114230804.jpg
    yaott2020
        8
    yaott2020  
       129 天前 via Android
    @Cipool wan 那里显示 fe80 是这样的,不是错误
    yaott2020
        9
    yaott2020  
       129 天前 via Android
    重启路由试试
    Cipool
        10
    Cipool  
    OP
       129 天前
    @Love4Taylor 谢谢回复,尝试手动新建一个 WAN6 接口,协议设置为 dhcpv6 ,但似乎没有作用。
    附图:[![7k0wAx.png]( https://s4.ax1x.com/2022/01/09/7k0wAx.png)]( https://imgtu.com/i/7k0wAx)
    szdosar
        11
    szdosar  
       129 天前 via iPhone   ❤️ 1
    在网络接口这里,你建一个新的 wan6 ,@wan 口,然后选择 DHCP V6 协议,正常应该就有 PD 下发了。
    我自己编译的包含 IP V6 组件,目前我使用正常
    https://github.com/szdosar/Actions-OpenWrt/releases
    acbot
        12
    acbot  
       129 天前   ❤️ 1
    首先,你得确认你所在得地方已经下发 v6 了。其次,如果之前你已经修改过防火墙等新闻这些我建议你把机器重置会默认状态,因为 ipv6 下发地址是需要 icmpv6 这些数据通过防火墙的。再次,一般来说默认状态的机器只需要在 @Buges #3 说的位置设置 wan 口的 option ipv6 'auto' 就可以正常获取了。根据你的截图明显你是 WAN 口就没获取到 v6 就不要说下面的机器了。一般来说运营商会下发 PD 所以除了 wan 口拨号后 DHCP 获取的 v6 还会在拨号以后多一个 wan_6 接口 里面 有 PD
    acbot
        13
    acbot  
       129 天前
    @szdosar 在拨号后上游有下发 PD 的时候路由器会自己建立一个 wan_6 虚接口
    Cipool
        14
    Cipool  
    OP
       129 天前
    @acbot 谢谢回复,如果用光猫拨号,在光猫网络配置里是可以看到,光猫能够获取可用 PD 前缀,下挂的路由器设置为 AP 模式,局域网设备也可以正常使用 IPv6 。
    我在拨号时确实自动生成了一个 WAN6 接口,但获取不到任何地址,图片链接同 #10 。
    Cipool
        15
    Cipool  
    OP
       129 天前
    @yaott2020 刚刚尝试多次重启,情况仍然不变,感谢回复。
    miyuki
        16
    miyuki  
       129 天前
    我是直接把 wan6 给删了,然后在 lan 里边设置分配自定义长度的 v6
    yaott2020
        17
    yaott2020  
       129 天前
    你的情况和我一样,无需新建 wan6 口,wan pppoe 拨号之后就会下发 ipv6 。我建议你换一个有带 ipv6 的固件,或者自己编译一个,lean 的 lede 编译 ipv6 需要勾选 ipv6helper ,如果换了固件还是不行,我觉得你需要问一下当地运营商
    yaott2020
        18
    yaott2020  
       129 天前   ❤️ 1
    还是不行的话,如果只是上网就退而求其次---nat6 ,如果需要对外开放还是公网 v6 好些,当然你也可以选择端口映射到内网,只不过麻烦而已。
    acbot
        19
    acbot  
       129 天前
    @Cipool 可以的话你最好重置或者是把 /etc/config/network 和 /etc/config/firewall 文件截图一下 让大家分析分析。
    cwbsw
        20
    cwbsw  
       129 天前
    既然光猫没问题那就说明电信上游设置是好的。
    但是你提供的有效信息太少了,没法帮你排查。
    所以只能建议你刷原版 OpenWrt ,不需任何额外设置即可完美支持 IPv6 。
    Cipool
        21
    Cipool  
    OP
       129 天前
    @acbot @cwbsw 感谢回复,附上 /etc/config/firewall 文件: https://write.as/3wq4y9vu7avrx.md
    /etc/config/network 文件: https://write.as/w0zys676vrpd2.md
    fhbyljj
        22
    fhbyljj  
       129 天前 via Android
    @Cipool 新版本不需要这个步骤,只需要在 WAN 设置自动管理 IPV6
    fhbyljj
        23
    fhbyljj  
       129 天前 via Android   ❤️ 1
    你可以试试 Lean 的,编译时候带上 IPV6 ,反正我是把禁止解析 IPV6 解除就能访问 IPV6 网站
    acbot
        24
    acbot  
       129 天前   ❤️ 1
    @Cipool 我看你的配置文件感觉 op 版本比较的高,你可以 先备份一下 /etc/config/network 文件然后删除下面 几行试试

    ...

    config globals 'globals'

    ...

    config interface 'wan6'
    option proto 'dhcpv6'
    option ifname 'eth1'
    option reqprefix 'auto'
    option reqaddress 'force'

    也就是删除 golobals 和 wan6 的配置文件然后重器网络(/etc/init.d/network restart)看看, 如果还是不行我也无能为力了,如果可以了那么你再去 /etc/config/firewall 文件 修改一下

    ...

    config zone
    option name 'wan'

    将 option network 'wan wan6' 修改为 option network 'wan'
    qbqbqbqb
        25
    qbqbqbqb  
       129 天前   ❤️ 2
    OpenWRT 拨号正常开启 IPv6 的话接口总览里面会有一个“WAN_6”(注意不是 WAN6 )的“虚拟动态接口”,是不需要在 interface 里单独配置 WAN6 这个接口的。如果没有的话检查一下你的 OpenWRT 版本是不是有问题(比如固件编译的时候没开相关功能)。

    另外如果你的固件里有“mwan3 多拨”插件也要关掉,这个不支持 IPv6 。
    notgoda
        26
    notgoda  
       129 天前 via iPhone
    @yaott2020
    @Love4Taylor
    @szdosar
    @acbot
    @miyuki
    @fhbyljj
    @qbqbqbqb 插楼请教各位 v 友, 我向 isp 申请到了公网 v4&v6 ,我是用光猫拨号,这光 猫的 wan 口已获取正确的 v4 和 v6 地址,但是 lan 口显示 ipv6 却是 fe80 开头的 ! 然后局域网的设备如 n1 也分配不到公网 V6 , 请教各位要改哪里的设置?谢谢🙏 [04618A19-895E-462A-84F2-9D6BE85E1AA6.jpeg]( https://s2.loli.net/2022/01/04/NilMRJTXn2pm5FA.jpg)
    ![45E9ADA6-D35B-4B79-AB38-984D1E253647.jpeg]( https://s2.loli.net/2022/01/04/zY4sUHLbyRcDavf.jpg)
    ![C8DF6F64-9EBA-4456-ABF5-56CC2B583411.jpeg]( https://s2.loli.net/2022/01/04/kIBOwfu2mXxArQ5.jpg)
    laincat
        27
    laincat  
       129 天前 via iPhone
    学习一下大家的设置
    nbweb
        28
    nbweb  
       129 天前 via Android   ❤️ 2
    https://kzpu.com/archives/4617.html
    原版 openwrt 的 ipv6 设置
    TsukiMori
        29
    TsukiMori  
       129 天前 via Android   ❤️ 1
    新建 wan6 接口 然后选择物理接口为 @wan 协议选 dhvpv6 获取前缀长度可以往大了选 56 60 的
    注意那个 @
    LGA1150
        30
    LGA1150  
       129 天前 via Android
    你检查下你刷的 rom 有没有 odhcpd ?
    vtoex0000000002
        31
    vtoex0000000002  
       129 天前   ❤️ 1
    Cipool
        32
    Cipool  
    OP
       129 天前
    @LGA1150 有的,odhcpd ,odhcp6c ,kmod-ipt-nat6 这些都有,现在也是找不到原因所在,可能只能上 nat6 解决问题了。
    xuwuyibing
        33
    xuwuyibing  
       129 天前   ❤️ 1
    你的固件似乎是第三方编译的老版本,按道理说 pppoe 以后可以获得两个 ipv6 ,一个 fe80 显示在 wan ,一个公网显示在虚拟 wan_6 ,你这个没有虚拟 wan_6 。
    没有虚拟的 wan_6 ,你有可能连 nat6 都不行。
    ysc3839
        34
    ysc3839  
       129 天前 via Android   ❤️ 1
    建议先试试官方 OpenWrt ,网上的修改版可能没有升级底层代码,存在旧版本中的 bug ,或者改坏了某些设置。
    @szdosar 官方的 OpenWrt 在连接 PPPoE 后是会自动出现一个虚拟的“wan_6”接口,默认就是设置为 DHCPv6 的,不需要手动设置。
    ysc3839
        35
    ysc3839  
       129 天前 via Android
    @notgoda 看你的图是设置成了光猫拨号,一般建议改成路由器拨号。如果真的不想改的话,先试试用电脑直接连接光猫,看看能否获得 IPv6 地址。
    acbot
        36
    acbot  
       129 天前
    @notgoda 因为你是光猫所以这个不可控因素就更多了,除非有人和你用一样的环境才能一起找原因,不然都不好说。 根据你的图我觉得 光猫 LAN 口没获取到 v6 地址不代表什么,主要是你下游设备开启 v6 以后能获取到不,你可以在下游设备抓包看看有没有 RA 啊 DHCP 啊这些包和包里面的数据,另外我看你 zY4sUHLbyRcDavf 这个截图 我感觉 IPv6 wan 信息获取方式不应该是 SLAAC 你换换看(这个纯个人猜测)
    zjm947373
        37
    zjm947373  
       129 天前   ❤️ 1
    https://openwrt.org/docs/guide-user/network/ipv6/configuration
    wan 口高级设置-获取 ipv6 地址设成自动,会自动生成一个 wan_6 接口
    如果没有那就设成手动,新建一个 wan6 类型是 dhcpv6 的接口,勾上桥接,自定义接口填'@wan',再不行调一下 wan6 口的设置,基本上就这样了
    fhbyljj
        38
    fhbyljj  
       129 天前 via Android
    fhbyljj
        39
    fhbyljj  
       129 天前 via Android
    按照这个设置试试
    imyoona
        40
    imyoona  
       129 天前
    没前缀不就是这个样子,Wan 不显示 v6 地址是正常的,Lan 要有前缀才能分到。
    之前电信网管没弄好的时候我也是这样的。
    yuchenr
        41
    yuchenr  
       129 天前
    去掉 lan 口的桥接。添加 lan6 ,接口为 @lan
    datou
        42
    datou  
       128 天前
    去恩山找个支持 IPv6 的对应机型 openwrt 刷入吧
    mizuki
        43
    mizuki  
       128 天前
    https://pan.baidu.com/s/1JSB_gg2yPQfO72-DbnGL8w?pwd=g667
    自己编译的固件,支持 IPV6 ,有需要可以试试
    [img][/img]
    doumeki
        44
    doumeki  
       128 天前
    很简单, IPV6 的地址不是在这里看的, 是在状态-->概览里看 IPV6.
    mahemin
        45
    mahemin  
       128 天前
    我图发不出来,
    我看你的光猫设置截图,你的光猫设置中,“LAN 端口绑定”,没有勾选任何端口???
    wyfbest
        46
    wyfbest  
       127 天前
    编译固件的时候 extra packages - ipv6helper 这个选上其他都不需要改动,填好拨号用户名密码其他都是自动的。之前我折腾的时候就是改乱了设置,结果人家早就全都配置好了。
    ZeroKong
        47
    ZeroKong  
       126 天前
    光猫 LAN 口不用绑定的吗?
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3186 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 24ms · UTC 04:34 · PVG 12:34 · LAX 21:34 · JFK 00:34
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.