V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
cathedrel
V2EX  ›  Linux

Manjaro 怎么设置“使用网络时间”?必须切换到 root 下面去设定吗?

  •  
  •   cathedrel · 99 天前 · 1211 次点击
    这是一个创建于 99 天前的主题,其中的信息可能已经有所发展或是发生改变。

    系统的时间一直是在慢慢的变慢,现在跟标准时间已经差了 4 分钟了,我想使用“网络时间”,但是在不管我怎么选定,关闭之后再打开时间设置的界面那这个“网络时间”一定是没选上的,是因为普通用户的设置不算数还是必须有其他我还不知道的设定方式??

    i.imgur.com/OA1nnD2.png

    13 条回复    2021-08-04 11:29:00 +08:00
    Cooky
        1
    Cooky   99 天前
    journalctl -e
    Zalica
        2
    Zalica   99 天前 via Android
    要在 manjaro setting 里面钩选相关选项才行。普通用户就行。我之前和你一样情况。就是在那里调置后解决的。
    cathedrel
        3
    cathedrel   98 天前
    @Cooky 这是啥?
    cathedrel
        4
    cathedrel   98 天前
    @Zalica 我进 manjaro 的“系统设置”--“日期和时间”,里面的“网络时间”是选上的。
    如果我再从右下角的时间进入“日期和时间”的设置界面,里面的“网络时间”又是没选上的;
    不改这个界面的选项,直接关闭,再去“系统设置”--“日期和时间”,里面的“网络时间”又变成未选上的了

    好奇怪耶
    harwck
        5
    harwck   98 天前 via Android
    sudo pacman -S ntp && sudo timedatectl set-ntp true
    no1xsyzy
        6
    no1xsyzy   98 天前   ❤️ 1
    要设置时间是需要管理员权限的,但不一定用 root,可以 polkit 授权。
    不过我没用过 manjaro,只好给你丢 arch wiki 了……
    https://wiki.archlinux.org/title/System_time#Time_synchronization
    no1xsyzy
        7
    no1xsyzy   98 天前
    @harwck 你这去装 ntp 包毫无意义
    timedatectl set-ntp true 用的是 systemd-timesyncd.service
    毕竟 timedatectl 就是 systemd 包提供的(
    Zalica
        8
    Zalica   98 天前   ❤️ 1
    @cathedrel 对,我也是相同的症状。所以要从 manjaro setting 的那个程序里设置,就是能选内核版本,能装驱动和语言文件的那个程序。
    cathedrel
        9
    cathedrel   98 天前
    @Zalica 你说的是“Manjaro Settings Manager”里面的“时间和日期”?那里面的确实跟前面我说的那个界面不一样,不过有没有效我现在不好说了,因为昨天晚上我已经通过安装 openntp 解决了问题

    sudo pacman -S openntpd

    systemctl enable openntpd
    cathedrel
        10
    cathedrel   98 天前
    @no1xsyzy 系统自带的可能就是 ntp,而且不好用,换成 openntp 就好了

    sudo pacman -S openntpd

    systemctl enable openntpd
    no1xsyzy
        11
    no1xsyzy   97 天前
    @cathedrel manjaro 作为 Arch 下游应当不是 ntp,默认带 systemd-timesyncd,但其他不确定
    当然,Manjaro 具体如何我就不清楚了
    反正还是命令行稳定,可供挑选的 ntp client 很多,GUI 就那么点信息很难搞懂它到底在玩蛇
    不过搜索引擎告诉我 KDE 需要的是 ntp 或兼容的命令行,Arch 默认是没装的,因此 Manjaro 也不太可能会装。
    silkriver
        12
    silkriver   97 天前
    Manjaro 设置时间同步可以参考这个短视频 https://www.bilibili.com/video/BV1AQ4y1Z7wj
    mortal
        13
    mortal   85 天前
    😂前两天在二奶机上装好 Manjaro,打开 Firefox 换源发现 HTTPS 证书全部错误,才发现时间是错的。也是设置这个使用网络时间无法成功。觉得 Linux 桌面离开箱即用真是还差得远。
    关于   ·   帮助文档   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1400 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 17:50 · PVG 01:50 · LAX 10:50 · JFK 13:50
    ♥ Do have faith in what you're doing.